Adobe PDF 10.1 

 

  The Books of the Bible on this web-site Require the Adobe Reader 6.0 - 10.1 to open the Books.

   Most computers have the Reader pre-installed from the manufacture, but it may need to be updated.

   If the Books are opening slow or not at all Click on the Link below to update or install the Free Reader.

                                                   http://www.Adobe.com/reader